Results 1 to 8 of 8

Thread: Implantation Bleeding or early period?

  1. #1

    Default Implantation Bleeding or early period?

    I just went to the bathroom to wipe and find bright red blood. When I start I always spot brown for a day or 2 before the red shows up. I am about 10 days past ovulation and on cycle day 26. What do you think?

  2. #2
    Join Date
    Jul 2011
    Location
    Michigan
    Posts
    9,471

    Default

    I think it very well could be if it's not your normal !! When do you plan on testing?

  3. #3

    Default

    Well I tested this morning and it was negative. I really thought that this might be it. No such luck not even 100% sure that I ovulated because my ovulation test never did come up positive this month. Feeling bummed.

  4. #4

    Default

    My temperature is still high 98.6 when should it drop? Should it drop as soon as bleeding starts or does it take a few days to drop? This is my first time charting. Thanks. Sorry still holding onto a little bit of hope

  5. #5
    Join Date
    Jul 2011
    Location
    Michigan
    Posts
    9,471

    Default

    I answered your other post .

    Did you get crosshairs for ovulation?

  6. #6

    Default

    I JUST stated charting my temps so I didn't chart for this full cycle. I stated checking my temps on day 18 of my cycle. So this is all new to me. How much is too much blood to be pregnant. I have STILL not fully started. Just brown blood enough to have to wear a pad but not much on the pad. Sorry TMI. Just trying to figure this OUT! It's driving me crazy lol. I think that I might have ovulated on Day 15/16 of my cycle - I got bright red blood steak on day 16 mixed with mucus but my ovulation test didn't pick it up! All I got was - this cycle. I test once per day around 8 p.m. at night. Do you think I am pregnant or am I just having a weird cycle. My temp was 98.3 today. My temps have all been 98.0 or above since I started charting.....

  7. #7

    Default

    ONE more thing I would like to add to my "puzzle" is that I THINK I have endometerosis. I have not been "officially" diagnosed because I opted to hold off on having surgery for a few months. Does endo cause bleeding if pregnant? Just thought I would put this out there....

  8. #8
    Join Date
    Jul 2011
    Location
    Michigan
    Posts
    9,471

    Default

    I'm so sorry things aren't more definite !!!

    It's hard to say with the bleeding...had I not gotten a + pg test I would have thought af had showed for sure at 11dpo because I had a medium flow for 4 days (I'll be 10wks pg tomorrow despite the bleeding and the occasional brown spotting I'm still having).

    If you haven't ovulated then the 98 degree temps may be a preovulatory temp for you . Since you weren't charting before and never got a +opk you may have ovulated really late and the spotting is implantation so you wouldn't get a + pg test for another day or two. Until you chart for a full cycle the info you have now will probably only be helpful in hindsight...I know it's a frustrating process when we want answers right now and being in limbo is the worst !!

    Really hoping and praying things become clearer over the next few days !!!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •