Results 1 to 5 of 5

Thread: Hmm, Could It be?! Cant wait to find out!

  1. #1

    Default Hmm, Could It be?! Cant wait to find out!

    I have had the Implanon rod BC for almost 3 yrs now. My scheduled date for removal is Jan 2 2013.. I have read that they can go "empty" before the 3 yrs are up. Which makes me wonder this. I have NEVER had a brown period before. Tmi- I know I'm sorry. But on the 6th I wiped and it was a thick mucus only brown, I freaked a little! I know it may be old blood but anyways, every 4 hours I would change my tamp and it was 1 drop of brown and the slightest hint of deep red each time. It lasted 3 days now its gone! It didnn't smell, I don't have cramps but I am nauseated. I ate just twice in 3 days but now I can eat but only so much! I pee constantly and keep taking cat naps. I will get a test but does tgis sound like a pregnancy or just a glitch in the ole AF

  2. #2

    Default

    I did fail to mention Husband and I never use protection except for the Implanon

  3. #3
    Join Date
    Nov 2008
    Location
    OKLAHOMA
    Posts
    2,222

    Default

    i would test

  4. #4
    Join Date
    Aug 2008
    Posts
    9,995
    Blog Entries
    1

    Default

    The only way to 100% prevent pregnancy is to not have sex. So, it's possible that you are - I just don't think that it is very likely.
    Jessica (33) and Ryan (33). Madelyn born August 5, 2009; Malachi born December 23, 2010 and Nathaniel born July 19, 2013. Lost a loved baby 02/29/12, 05/14/12 and 07/05/12 all due a serious allergic reaction to fabric softener.
    My Ovulation Chart , My blog about MCAD

  5. #5
    Join Date
    May 2011
    Location
    EVV IN
    Posts
    6,310

    Default

    I've heard of those failing before so its possible. Test for a piece of mind.



Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •